
Manual for QuiltAssistant v2.10
By Arnout Cosman, 12 May 2009.
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What's New?
If you are familiar with any of the earlier versions of QuiltAssistant, this list will quickly bring 
you up to speed on the new features to be found in QuiltAssistant v2.10. If you are new to 
QuiltAssistant, you may wish to skip to the introduction below and come back here later.

1. Draw curved lines: you can now draw 'free-hand' curves directly, without using the 
Edit mode.

2. Drag curves: in Edit mode, you can now click and drag to change the curve of lines 
in a natural and easy-to-use way.

3. Partition lines: in Edit mode, you can now sub-divide lines into equal segments, 
useful to connect new lines in a controlled way.

4. Add borders: you can now add borders to your existing design.
5. Color Dialog: the color dialog now includes a 'palette' feature, where you can build 

a selection of colors (and save them separately for later use). You can use this 
palette to color your design with, and also apply the palette to the entire design to 
make sure only those colors are used in it.

6. Fabric Usage Print: the option to print a list of all fabric colors used including 
estimates of the amount of fabric required for each color. If you based your design 
on an image, you may need to reduce the number of colors in the design before 
using this feature.

7. Label unique colors on print: if your design contains a limited number of colors, 
these will be numbered on your templates so you know which template uses which 
color.

8. Export design as vector drawing: export to WMF (Windows MetaFile) or EMF 
(Enhanced MetaFile) for use in other drawing software.

9. Regular pattern for printing: when creating a new regular pattern, you can set it to 
fit a single sheet of paper. Handy for printing template-sheets.

Introduction
This manual shows you how to use QuiltAssistant for two different tasks. The first is to 
design a quilt based on a picture, the second to draft traditional quilt blocks quickly and 
conveniently. Whichever you want to do, when you fire up the software for the first time, it 
will ask you to configure some basic settings.
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Choose your units of measurement (inches or centimeters), and, most importantly, the 
correct seam width. Be as accurate as possible, the software doesn't mind about the 
number of postcomma digits.
Some other settings worth mentioning at this point:

 Check for software updates: by default, QuiltAssistant will check if a newer version 
is available, if an Internet connection is available.

 Screen diagonal: here you can set the size of your computer screen. If you do not 
the correct value, you can use the 'measure' to measure it yourself. You can safely 
leave this setting untouched, but when you set the right size, QuiltAssistant will be 
able to show your design true to scale.

You can always change these settings at a later stage using the menu option 
File=>Preferences.
Now that the basic settings are configured, you can choose to continue to design a quilt 
based on a picture, or skip to the section on drafting traditional quilt blocks. If you 
want to use QuiltAssistant to design your own paper piece patterns, you will find useful 
information in both sections.

Quilt based on a picture
Desiging a quilt based on a picture begins with the right source material. So in preparation, 
you should take care in selecting a suitable photo or other image. Things that determine 
how suitable a particular image is:

 Avoid too many details: you will most likely loose them in the finished quilt, making it 
hard to recognize the depicted object.

 Familiar imagery: human faces and shapes, trees, flowers, etc. are easier to 
recognize than e.g. an 'objet d'art'.

 Choice of colors: images that are colorful and rich in contrast are easier to convert 
into pieces of fabric.

Sometimes it can be a good idea to experiment in advance with colors and contrasts in the 
original image, using generic image editing software.
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Start a project
The startup screen allows you to create a new project based on a picture, or load one of 
your earlier projects, if you have any.

To start a new design: click on 'Create a new project (browse for a picture)' and find a 
suitable picture on your computer. After you select one, the following dialog will appear:

Under 'Quilt/Block Size', determine the width and height of the quilt. Beware though: the 
final output of the program is a set of templates on paper and for a quilt of 40” by 40” that 
can be 50 sheets of paper (letter or A4 format).
In this example I use 12” by 12” to cut the losses to a couple of sheets.
Click 'OK' to close this window, at which point we arrive at the most important step:

Save
Save the file, menu File=>Save, (rinse and) repeat regularly. During your work, the 'Undo' 
option helps you to return to a previous state, but it is nonetheless advisable to save 
regularly in case something goes haywire.
Save the QuiltAssistant File (with extension .QA2) in the same directory as the original 
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image and keep them together. QuiltAssistant does not make its own copy of the image 
and expects to be able to access both files in order to retrieve its data.

Dividing the image
The procedure to split the image into pieces is very simple: click (left mouse button) 
somewhere in the image and drag the mouse to another point. This draws a dashed line 
which will be the dividing line for the image. When you release the mouse button this line 
extends to the borders and the image is split in two pieces.

The software calculates an 'average' color for each of the pieces, which you can use to 
find matching fabrics. Using 'Display=>Shapes' you can see these calculated colors, 
'Display=>Image' returns you to the original image, 'Display=>50%' shows a blend of the 
two. Alternatively, use to color slider to set this value:

Other things you need to know when dividing the image:
 The menu Zoom allows you to zoom into details to work on smaller pieces. For this, 

you can also you the scroll wheel on your mouse, or the zoom slider on the toolbar:

 When you draw a line through multiple pieces, all of these pieces will be split.
 If you want to work on a regular pattern, you can use the option 'Display=>Snap to 
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grid' (and its associated settings under 'Display=>Grid/snap settings')
 To make a new division end in existing corner: 'Display=>Snap to corner'.
 The maximum distance between the mouse pointer and a snap point can be 

changed using this toolbar setting (make sure you press <enter> to confirm any 
changes):

And this is a simple example of an image divided into pieces:

Removing lines
Because lines are always extended to the edges of the piece you are working in, you will 
sometimes end up with unwanted line segments you want to remove to clean up the 
design. To remove a line segment, simply right click on it. Be careful, though: once you 
start removing line segments, you quickly run the risk of creating a design that is hard to 
(machine) piece.
On the other hand, if you manage to create your design without ever removing or editing 
lines (except for the use of the Undo function), you will end up with a design that is 
guaranteed to be paper piecable.

Statistics
At some point you will ask yourself: how big are these pieces I keep dividing, is this still 
doable? Enter menu option Windows=>Information.
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In this window you can find:
 The total number of pieces in the design. Very important if you need something to 

brag about, otherwise totally irrelevant.
 The area/width/height of the selected pieces. You can select a piece by clicking 

inside it without dragging the mouse.
 The biggest area/width/height found in the design (these do not necessarily all refer 

to the same piece). Especially useful to find out if each of your pieces will fit on a 
single sheet of paper.

 The smallest area/width/height found in the design (these do not necessarily all 
refer to the same piece). This should give you an indication of whether or not you 
will still like to actually make this quilt.

When you click on one of the lines, e.g. 'Smallest width', the matching piece in the design 
(having the smallest width) will be selected, so you can see which one it is.

Preparation for printing
When you are happy with your design, and after you save it (!), do not just do a 
'File=>Print', but have a look at the 'Shape Tree' first (menu Window=>Shape Tree). 
Here you can see all the pieces you created in a tree structure. When you select a line in 
this tree, you will see the corresponding selection in your image. Use this feature to give 
your pieces an intelligible name.
When you click for a second time on an already selected line in the tree, you can change 
the name of the node. The names of the underlying nodes will automatically be changed to 
match.
If you do not do this, generic names will be used, like A.D.C.A.E.F.A. During printing, the 
pieces are sorted to fit as many as possible on a single sheet, so if you do not change the 
names, you will end up with a giant jigsaw puzzle. Never mind, jigsaws can be fun, too.
The tree structure can also help you to match printed pieces to the design and to 
determine the best order to sew them together.
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Printing
You can print all of the pieces in one go, but you can also make a selection. The latter can 
be useful if you lost some pieces or want to print just a couple of pieces from a regular 
pattern. Use the checkmarks in the tree structure, or choose menu option 'Mode=>Select' 
to show the selection in the image itself. Darker pieces are selected, lighter pieces are not 
selected. Left mouse button: select, right mouse button: deselect.

When you select 'File=>Print' (or 'File=>Print Preview'), the following dialog appears:

You can print templates (all, or only the selected ones) by selecting a suitable preset from 
the list. The checkboxes below the preset box allow you to make your own custom 
selection of details to print.
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You can also use the 'printable fabric' preset to create your own 'cheater fabric' by printing 
parts of the original photo on a selection of the shapes.
Click on the 'design' tab to make an overview print of the entire design, including the 
names of all shapes:

Use the 'Quick Preview' button on the right to get an impression of what will be printed, or 
the 'Full Preview' button on the left to get a complete preview of every page to be printed.
The print preview helps you to estimate how many pages you will need to print the design. 
Beware that small discrepancies in margins and the printable area of the printer can cause 
the arrangement of the templates on the final print to differ significantly from the print 
preview.

Making the quilt
There are, of course, many ways to do it, but here is my way:

 Cut the templates and sort them, based on the names I gave them.
 Layout a part of the templates on a desktop and find matching fabrics.
 I cut the fabric using a small rotary cutter, along the paper templates.
 Piece/sew together in the correct order. If you do things right, you will only need to 

sew straight lines on your sewing machine, without any inset corners or other 
difficulties.

Regular patterns
To make a quilt based on a simple grid of squares or triangles, use the 'regular pattern' tab 
when starting a new quilt design (File=>New). You can now choose the pattern type 
(squares, squares on point, or triangles), the size of each square/triangle and the number 
of division in horizontal and vertical direction. After creating a regular pattern you can add 
further details as described above.
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Editing a design (advanced)
Using the Mode=>Edit menu option you can make changes to your existing design. In Edit 
mode, the following things can be done:

 Move existing corners: Click on a corner and drag it to a new position. If you move 
the corner to an impossible position (one that would cause edges to cross other 
edges, for example), the corner will snap back to its original position.

 Create new corners: Press and hold the CTRL-key, then click on an edge and drag 
it to a new position. A new corner will be inserted on the edge.

 Partioning: Right-click on a line to show a context menu, and select 'Partition'. 
There you can split the line into equal-sized segments, the added points can then 
be used to connect new lines to.

 Deform an existing edge: Click and drag any part of a line to make to into a curve. 
This is an easy way to create any shape you like, but for more precision, you may 
also want to try the following method to do the same thing.

 Modify an existing edge: Click on an existing edge. It will be selected for editing as 
a bezier spline. This means you will see two so-called control points, indicated by 
little squares, that you can drag to a new position. Dragging a control point will 
cause the edge to curve in the direction of this control point. If you have no 
experience with this, you probably need to see/do it to understand what that means. 
Click somewhere outside the edge and its control points to apply the change to the 
design.
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When editing a design like this, be aware that you can easily create all sorts of inset 
corners and curves that can be very difficult to turn into patchwork.
If you want to practice with the editing features, here is a challenge for you:

Try to make this design (consisting of just 2 shapes) by moving and adding corners and 
modifying edges. You may need to 'think outside the box' for this one, but if you can do it 
you should have a good understanding of the possibilities and limitations of the Edit mode.

Drafting traditional blocks
QuiltAssistant helps to draft traditional quilt blocks in record time by making use of the fact 
that there is a lot of symmetry in most quilt blocks. This section will show you quick and 
easy ways to draft some well known blocks. Once you know the techniques, you can use 
them to draft other traditional blocks, or experiment and make your own unique creations. 
QuiltAssistant makes it easy for you. Not convinced yet? Then read on!

First steps
For these examples, we will make blocks of 6” x 6”. When you start QuiltAssistant, choose 
the option 'Create a new blank project' to start:
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Then, in the Quilt/Block setup dialog, set the width of the block to 6” (the height will 
automatically follow this setting):

Click 'OK' to accept this setting. QuiltAssistant then shows the blank canvas for you to 
work on. You will need these basic steps for each of the blocks shown below.

Ohio Star
This first example shows you how to draw the Ohio Star pattern. After creating a blank 6” x 
6” block as described above, set up a grid to align your pattern to. To do this, click on the 
little downward pointing arrow next to the 'Snap to grid' button on the upper toolbar, then 
select '3x3' from the list.
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Like most traditional blocks, the Ohio Star is highly symmetrical, so use the symmetry tool 
to save time: click on the downward point arrow next to the 'Symmetry' button and select 
'4 Rotations' from the list.

After these preparations, drawing the block is easy. Looking at the picture below, draw a 
line from point 1 to point 2, by clicking and dragging the mouse. Watch the mouse cursor, 
it will show a little magnet when it snaps to the grid, so you will know you draw a perfect 
vertical line.

Should you make a mistake, use the 'Edit=>Undo' (or Ctrl-Z key combination) to undo it. 
The symmetry tool will automatically complete the grid for you. Repeat this for the next 
line:
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And that is it! With 2 simple lines you created the complete Ohio Star block. Let's give it 
some color to improve its looks. Click on the coloring icon on the upper toolbar:

You will get an extra window with a selection of colors. To start coloring, simply click on a 
color from the palette, then click in you design to apply the color. The symmetry tool will 
make light work of coloring as well, by coloring 4 patches with 1 click.

Complete the block in whichever colors you fancy. Some tips: right-click in the design to 
'pick up' a color for re-use elsewhere, ctrl-click to replace a single color throughout the 
design.
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Dutchman's Puzzle
This block follows the same basic principles as the Ohio Star, so you may want to look 
back at it for more detailed instructions. First create a 6” x 6” blank canvas, as described 
above, then set the 'Snap to grid' to '4x4' and set the 'Symmetry' to '4 Rotations'. Now 
we are ready to draw, the first line goes from the top middle straight down:

The second line divides one of the little squares in half, the symmetry tool will do the work 
for the other squares.
Just keep drawing the lines in one quarter of the design, and let the symmetry tool do rest:
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As before, the coloring tool makes quick work of completing your design. Tip: If you do not 
want the coloring to be symmetric, set the 'Symmetry' tool to 'None'.

Naming the shapes: if you want to name the shapes in a design to indicate a certain 
sewing order, use the menu 'Mode=>Naming' (or press 'N'). Click each shape in the 
desired order to name them. Each shape you click will turn dark and be named A1, A2, A3 
and so on. When you click a shape twice, it will be the start of a new series (B1, B2, B3 
and so on). If you make a mistake, you can redo part of your work by clicking on the 
wrongly selected shape to deselect and try again.
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Eight-Point Star
This design is a bit more difficult to create. Start with a 6” block, as before, and set the 
'Snap to grid' to '10x10'. For 'Symmetry' we use '4 Rotations' as before (see Ohio Star 
for detailed instructions). Because of the special shape of the 8-point star, we will use the 
'Point to Point' setting to draw the lines (change the 'Straight Line' setting on the 
toolbar):

Now, following the picture below, first left-click on point #1, then left-click on point #2, and 
finally right-click on point #3 to finish drawing the first point-to-point line (picture on the 
left):

Repeat the exact same sequence for the second line (on the right). Now that you a feel for 
the process, you should be able to complete the shape without too much trouble:
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Of course, no block is complete without a little color:

Log Cabin Variation
This variation on the Log Cabin block shows you some new tricks that makes this design 
easy and fun to draw. Start with a 6” block and set the 'Symmetry' to '4 Rotations', and 
make sure to switch the 'Snap to Grid' off (we don't need it for this block). Instead, switch 
on the 'Snap to Corner':

Now move your mouse to a point as close as possible to the top of the block, at about a 
1/6 (1” on a 6” block) from the left, and click and drag to point #2 as shown below:

Notice that the mouse cursor will 'snap' to the start of the next line, created by the 
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symmetry tool. Repeat this process to create the next square-in-a-square:

This is easy! Add a couple more to complete the look. Remember to use the Undo 
function (Ctrl-Z key combination) if you don't get it quite right the first time. When you are 
happy with the result, it is time to start coloring. 

We will use a special function of the coloring tool to quickly get a range of shades: first pick 
your favorite color (1) then click on the 'Color Values' (2) to show a set of shades based 
on this color. Using these shades, a perfectly colored block is just a few mouse clicks 
away.
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Try some variations, maybe by setting the 'Symmetry' to '2 Rotations' and coloring in 2 
different sets of shades. Or create a completely new block with 'Symmetry' set to 3 or 5 
rotations.

Wheel of Mystery
This block is all about getting the right kind of curves and will show you some advanced 
tricks. As always, start with a 6” block and set the 'Symmetry' to '4 Rotations'. Then set 
the 'Snap to Grid' to '2x2', and also set the 'Symmetry' to 'Mirror Left/Right'. Note that 
you combine 2 different symmetries (mirroring and rotation) to end up with an 8-fold 
symmetry.
Now, to get the perfect curves, we are going to work 'outside the box'. To do this, zoom out 
a little, then click and drag the bottom right corner of the design window to increase its 
size. When you do this, scroll bars will appear, allowing you to move beyond the design 
canvas. As you can see, the grid also extends into this area.
We are going to draw quarter circles, so select 'Quarter Circle' instead of 'Straight Line' 
on your toolbar.
Wow, that was a lot of preparation, but it will pay off! Draw your first arc from point 1 
(outside the design canvas) to point 2 (center) as shown below:
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When you release the mouse, QuiltAssistant will keep only the parts of the arcs that are 
inside the design area and remove the rest. Eight perfectly symmetrical arcs finished, and 
only 1 step to go:

Note that as you move your mouse from point 1 to point 2, you should more or less follow 
the path of the arc that you are trying to draw, because QuiltAssistant will track your 
movements to decide which way to flip the arc.
Color the block to get the finished article:

To see this block in its full glory you would need a couple of different colorings and a quilt 
to arrange them in. So if you have Electric Quilt 5 or 6, now would be a good time to try the 
export function in QuiltAssistant: menu 'File=>Export=>To Electric Quilt'. Alternatively, 
you can also export to a vector drawing for use in other software programs.
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